Thứ Ba, 1 tháng 12, 2020

Các câu lệnh quản lý mạng trong Solaris

Show installed NIcs: 
--Ban 11
#dladm show-link

# dladm show-dev

Ping Kiểm tra kết nối

# ping 8.8.8.8
--ping có nhãn thời gian
# /usr/sbin/ping -s 192.168.1.87 | xargs -n1 -i bash -c 'echo `date +"%Y-%m-%d %H:%M:%S"`" {}"' \n
/usr/sbin/ping 192.168.1.87| xargs -n1 -i bash -c 'echo `date +"%Y-%m-%d %H:%M:%S"`" {}"'  >> /tmp/ping_log.log &
# ping -s 192.168.1.99

Find unknown NIC
: When you do not know the network interface name and don't want to guess: simple plumb all unplumbed NICs with
ifconfig plumb -a

From <https://lzone.de/cheat-sheet/Solaris> 

Check các hop đến đích
# traceroute 8.8.8.8
(From: 192.168.1.87)

- Traroute qua gate (nếu Server có từ 2 GW trở lên):
traceroute -i igb2 192.168.1.87
Xác định IP khi biết Name Server
# nslookup www.mobifone.com.vn

Show bảng định tuyến
# netstat -rn
(From: 192.168.1.87)


-- Default route
# vi /etc/defaultrouter
192.168.1.1
reboot to test.

- Add gateway:
#route add default 192.168.1.99
- Dele gateway:
# route delete default 192.168.1.99
- Add/remove static route

Check port
# netstat -an |more

# netstat -an |grep ESTABLISHED
# netstat -anf inet

Check port 7809 co mo khong: ssh 10.50.9.55 -p 7809 -v
telnet 10.50.9.55 7809

1. Tìm card mạng đang active trên hệ thống
Ví dụ: IP máy chủ 10.50.8.185 card mạng đang active là bge0
root@backup02 # ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
        inet 127.0.0.1 netmask ff000000 
bge0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500 index 2
        inet 10.50.8.185 netmask ffffff00 broadcast 10.50.8.255
        ether 0:21:28:7e:65:68
 
2. Plumb ip ảo
ifconfig bge0:1 plumb
 
3. Cấu hình ip cho card ảo
ifconfig bge0:1 10.50.8.186 netmask 255.255.255.0 up
 
4. Cấu hình để khi hệ thống reboot không bị mất cấu hình
 
touch /etc/hostname.bge0:1
 
echo "10.50.8.186" >>/etc/hostname.bge0:1

Change IP without reboot

Changing the IP address of a Solaris 10 host without a reboot
23 Mar, 2009 Solaris0
It is possible to change the IP address of a solaris 10 host by modifying couple of files.  Here is how:
The ip address of the system is placed under /etc/hosts. This file actually is symbolically linked to /etc/inet/hosts in Solaris 10. In my system, I have the following in my /etc/hosts
# cat /etc/hosts
::1     localhost
127.0.0.1       localhost
192.168.1.122   opensolaris     loghost
So I am going to change IP address from 192.168.1.122 to 192.168.1.123. Edit the /etc/hosts file with a text editor of your liking:
#vi /etc/hosts
::1     localhost
127.0.0.1       localhost
192.168.1.123   opensolaris     loghost

Since this file is sym linked to /etc/inet/hosts, you should be able to see the change:
# cat /etc/inet/hosts
::1     localhost
127.0.0.1       localhost
192.168.1.123   opensolaris     loghost
At this point you should also change the IP address in /etc/inet/ipnodes .
Now use ifconfig command to make the change effect immediately.
# ifconfig pcn0 192.168.1.123 netmask 255.255.255.0
# ifconfig -a
lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1
inet 127.0.0.1 netmask ff000000
pcn0: flags=201000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4,CoS> mtu 1500 index 2
inet 192.168.1.123 netmask ffffff00 broadcast 192.168.1.255
If you want to have changes take effect across reboots, you can restart the network/physical service:
# svcadm restart network/physical
That’s it…Now you’ve changed the actual IP address without even rebooting….
From <http://www.machine-unix.com/changing-the-ip-address-of-a-solaris-10-host-without-a-reboot/> 


Ref: 
1-/etc/hostname.interface_name 
2-/etc/hosts   (~/etc/inet/ipnode)
3-/etc/netmasks 
4-/etc/defaultrouter
5-dns


Kill 1 session
Sử dụng tcpdrop để ngắt một kết nối TCP:
Ví dụ ở đây mình thiết lập 2 kết nối TCP bằng cách SSH tới Server như kết quả sau
# netstat –an|grep EST

Thử ngắt kết nối thứ hai bằng công cụ tcpdrop
# tcpdrop 192.168.2.129 22 192.168.2.10 1435

Trong đó:
• 192.168.2.129 là địa chỉ IP của Server
• 22 là TCP port của dịch vụ SSH trên Server
• 192.168.2.10 là địa chỉ IP của Client
• 1435 là port mà SSH client lắng nghe.
• Kill trạng thái CLOSE_WAIT
netstat -an |\
grep 127.0.0.1 |\
grep ':9000 ' |\
grep CLOSE_WAIT |\
awk '{print $7}' |\
cut -d \/ -f1 |\
grep -E "[[:digit:]]{1,}" |\
xargs kill

Check MAC Default Gateway
Them dia chi MAC vao default gateway
arp -s 10.151.3.99 00:03:d2:26:e1:2f
Kiem tra dia chi MAC cua default Gateway
arp -a | grep 3.99

Check số đường interconnect
-- Check các đường interconnect
# oifcfg getif

Check tốc độ cạc mạng
root@testcard2 # dladm show-dev

ce0             link: up        speed: 1000  Mbps       duplex: full
ce1             link: up        speed: 1000  Mbps       duplex: full
ce2             link: down      speed: 0     Mbps       duplex: unknown
ce3             link: up        speed: 1000  Mbps       duplex: full
ce4             link: up        speed: 1000  Mbps       duplex: full
ce5             link: up        speed: 1000  Mbps       duplex: full

Lệnh check băng thông card:
-Solaris:
#dladm show-dev
-Redhat:
#ethtool eth0
-AIX:
#netstat -v
-solaris 11:
 dladm show-phys

Trace snoop
snoop vs. tcpdump: How to use snoop:
snoop -v -d qfe0 -x0 host 192.168.1.87
snoop -v -d qfe0 -x0 port 22
# snoop 
snoop -d bge1 -o /s03/soap.pcap tcp 192.168.1.87


From <https://lzone.de/cheat-sheet/Solaris> 

Trace all bản tin:
 
root@sol10 # /usr/sbin/snoop -d igb0 -o /u01/app/dangth/output.pcap -q -r &
[1] 25414
 
Trace theo IP: 
 
root@sol10 # /usr/sbin/snoop -d vnet0 -o /u01/dangth/tracehlrgw.pcap -q -r  192.168.1.87 &
[1] 25414
 
Trace theo port: 
 
root@sol10 # /usr/sbin/snoop -d nxge0 -o /u01/app/dangth/pne.pcap -q -r  port 1521&
[1] 25414
 
 
Khi cần dừng trace:
 
root@vms-pne # ps -ef | grep snoop
    root 19014 19012   0 19:05:35 pts/9       0:00 grep snoop
  nobody 25414     1   0   Nov 07 ?           0:03 /usr/sbin/snoop -d nxge0 -o /u01/app/binhtv/app1.pcap -q -r 192.168.1.87
root@vms-pne # kill -15 25414

-d là tên card mạng, -q, -r giữ nguyên, anh thay IP hoặc port vào thôi

-o là sẽ ghi ra file


Khởi động lại hệ thống vẫn như cũ, không lấy được địa chỉ IP. 
Sau khi kiểm tra file cấu hình thấy file cấu hình /etc/hosts đã thay đổi ko chuẩn nên hệ thống không lấy được địa chỉ IP (file /etc/hosts là file cấu hình lưu địa chỉ IP của hệ thống)

Tương tự, hệ thống node2 (chưa sửa)

Sau khi sửa file cấu hình /etc/hosts của node1 về chuẩn:

Boot lại hệ thống đã lên & hoạt động.
Others
# tcpdrop
# tcpdump
 
Bge1: Là tên card mạng giao tiếp tới network ngoài (có thể ipconfig sẽ có thông tin).
/s03/soap.pcap: Địa chỉ sẽ lưu file trace nhé.
192.168.1.87: Fileter tới IP (nếu cần giảm các bản tin thừa khác).

(Ghép 2 IP vào 1 lệnh chắc làm dc, nhưng anh chưa thử), nếu không thì trace all, ví dụ như: snoop -d bge1 -o /s03/soap.pcap

# dladm show-dev -- Check speed NIC


KẾT NỐI VỚI CHUYÊN GIA TRẦN VĂN BÌNH: 📧 Mail: binhoracle@gmail.com ☎️ Mobile: 0902912888 ⚡️ Skype: tranbinh48ca 👨 Facebook: https://www.facebook.com/BinhOracleMaster 👨 Inbox Messenger: https://m.me/101036604657441 (profile) 👨 Fanpage: https://www.facebook.com/tranvanbinh.vn 👨 Inbox Fanpage: https://m.me/tranvanbinh.vn 👨👩 Group FB: https://www.facebook.com/groups/OracleDBAVietNam 👨 Website: http://www.tranvanbinh.vn 👨 Blogger: https://tranvanbinhmaster.blogspot.com 🎬 Youtube: http://bit.ly/ytb_binhoraclemaster 👨 Tiktok: https://www.tiktok.com/@binhoraclemaster?lang=vi 👨 Linkin: https://www.linkedin.com/in/binhoracle 👨 Twitter: https://twitter.com/binhoracle 👨 Địa chỉ: Tòa nhà Sun Square - 21 Lê Đức Thọ - Phường Mỹ Đình 1 - Quận Nam Từ Liêm - TP.Hà Nội #OracleTutorial #OracleDBA #OracleDatabaseAdministration #học oracle database #oca #ocp #oce #ocm

ĐỌC NHIỀU

Trần Văn Bình - Oracle Database Master